Projects / TOMOYO Linux / Announcements / OpenSUSE 11.3 will fail to ...

OpenSUSE 11.3 will fail to boot with TOMOYO 2.3

We found that OpenSUSE 11.3 will panic if TOMOYO 2.3 is enabled. Please apply the following patch. New ccs-tools release should be available soon. Sorry for the inconvenience to all OpenSUSE users.

> --- sbin/tomoyo-init.c
> +++ sbin/tomoyo-init.c
> @@ -306,7 +306,7 @@
> if (lstat("/proc/self/", &buf) || !S_ISDIR(buf.st_mode))
> proc_unmount = !mount("/proc", "/proc/", "proc", 0, NULL);
> /* Mount /sys if not mounted. */
> - if (lstat("/sys/kernel/", &buf) || !S_ISDIR(buf.st_mode))
> + if (lstat("/sys/kernel/security/", &buf) || !S_ISDIR(buf.st_mode))
> sys_unmount = !mount("/sys", "/sys", "sysfs", 0, NULL);
> /* Mount /sys/kernel/security if not mounted. */
> if (lstat("/sys/kernel/security/tomoyo/", &buf) ||
>

Screenshot

Project Spotlight

BaseX

An XML database and XQuery processor.

Screenshot

Project Spotlight

Firejail

A Linux namespaces sandbox program.