Projects / PPTP Client / Comments

Comments for PPTP Client

10 Nov 2002 17:02 tooraweenah

Re: Cannot run in Mandrake 9.0

> I cannot get this to function in Mandrake 9.0 either... at first I get the insecure dependency error, then all other attempts to use it result in timeouts. And yeah, I have the latest version :)

Please read the web site (http://pptpclient.sourceforge.net/) for the project, the documentation (http://pptpclient.sourceforge.net/documentation.phtml) section has a Diagnosis HOWTO (http://pptpclient.sourceforge.net/howto-diagnosis.phtml) that describes solutions to most problems reported. Insecure dependency error (http://pptpclient.sourceforge.net/howto-diagnosis.phtml#insecure_dependency) is one such.

After that, use the project mailing list archives (http://sourceforge.net/mailarchive/forum.php?forum_id=773) to check for others who have had the same problem, or post to the mailing list (http://pptpclient.sourceforge.net/contact.phtml) yourself. We don't monitor the freshmeat comments list as if it is a support forum.

08 Nov 2002 17:10 Vermyndax

Cannot run in Mandrake 9.0
I cannot get this to function in Mandrake 9.0 either... at first I get the insecure dependency error, then all other attempts to use it result in timeouts. And yeah, I have the latest version :)

30 Aug 2002 19:23 tooraweenah

Re: Works great

> log[decaps_gre:pptp_gre.c:215]: short read (4294967295): Protocol not available

Yes, on the same machine or on a slow client connected over a short fast link to a fast server, this will happen. It was caused by not binding the GRE socket before making the connection to the server.


It was fixed in CVS as of 2002-08-07.


http://pptpclient.sourceforge.net/pptpclient/howto-diagnosis.phtml#read_eproto (http://pptpclient.sourceforge.net/pptpclient/howto-diagnosis.phtml#read_eproto)


James

26 Jun 2002 22:04 Willis

Re: Works great
What kernel are you using?
i've been running a pptp server on a patched 2.4.7-10 kernel and it works fine, but when i try a client on the same machine i get the error message:
log[decaps_gre:pptp_gre.c:215]: short read (4294967295): Protocol not available
and the connection is unsuccessful.
I couldn't find anything relevant in the diagnosis section but i found a posting on a newsgroup from a guy with the same error and apparently it's kernel-related.
any tips would be appreciated

12 Feb 2002 19:56 tooraweenah

Re: Can't Install with RedHat 7.2 Kernel 2.4.7-10
The development team is working to rebuild the packages against later kernels, and would welcome assistance. Please join the project if you are able to assist.


In the meantime, the solution posted 10th February 2002 on the pptpclient-devel mailing list was to rpm --rebuild the ppp-mppe source package, and then install with --nodep.

12 Feb 2002 18:33 rbratton

Can't Install with RedHat 7.2 Kernel 2.4.7-10
I have kernel 2.4.7-10 (RH 7.2). I haven't rebuilt a custom kernel yet.

When I try to install the rpm, I get the following message:
error: failed dependencies:
ppp <= 2.3.15 conflicts with kernel-2.4.7-10

Forgive my ignorance, but what does this mean, exactly?

Is there a newer binary distribution?

Do I need to build from the source RPM?

Thanks,
Rob

26 Sep 2001 22:58 whitemice

Works great
I've been using this PPTP Linux client for over a year now and it works fabulously. It seems to help (at least with my Linux box) to disable most of the compression options in PPP, before that I had 40-60% packet loss. Now my packet loss hovers around 1%, and performance is very good (DSL client side, T1 host side). It does make kernel upgrades a bit more of a pain as you need to rebuild the MPPE PPP modules every time.

Screenshot

Project Spotlight

ReciJournal

An open, cross-platform journaling program.

Screenshot

Project Spotlight

Veusz

A scientific plotting package.