Projects / Imlib2 / Comments

Comments for Imlib2

23 Apr 2007 11:37 dhuber23

Where to find newer versions
Avoid the problems that others have had with the version of imlib2 here (1.0.6). Newer versions of this project can be found on sourceforge within the enlightenment project. At the time of this writing, version 1.3.0 is current.

http://sourceforge.net/project/showfiles.php?group_id=2

06 Oct 2004 16:54 joehill

Where is Imlib2 1.1.1
I see references to Imlib2 1.1.1, but the only version I can find for download is 1.0.6, which is what I have installed already.

Where to download 1.1.1?

12 Sep 2004 13:03 tvashtar

imlib2-1.1.1 install problem
im trying to install enlightenment DR16.7 and so im installing the

dependencies first, however i have hit a problem trying to build

imlib2-1.1.1

i run my configure script fine but when i run make i get an error after a

few seconds.

here is my terminal output.....

[tvashtar@HAL9000 imlib2-1.1.1]$ ls

aclocal.m4 imlib2.pc

AUTHORS imlib2.pc.in

autom4te.cache/ imlib2.spec

ChangeLog install-sh*

config.guess* libtool*

config.h loaders/

config.h.in ltmain.sh

config.log Makefile

config.status* Makefile.am

config.sub* Makefile.in

configure* missing*

configure.in mkinstalldirs*

COPYING README

demo/ src/

doc/ stamp-h

filters/ stamp-h.in

imlib2-config* test/

imlib2-config.in TODO

[tvashtar@HAL9000 imlib2-1.1.1]$

[tvashtar@HAL9000 imlib2-1.1.1]$su

Password:

[root@HAL9000 imlib2-1.1.1]# ./configure

checking build system type... i686-pc-linux-gnu

checking host system type... i686-pc-linux-gnu

checking target system type... i686-pc-linux-gnu

................................................

config.status: config.h is unchanged

config.status: executing default-1 commands

config.status: executing default commands

[root@HAL9000 imlib2-1.1.1]#

[root@HAL9000 imlib2-1.1.1]# make

make all-recursive

................................................

gcc -shared .libs/libImlib2.la-36.o -L/usr/X11R6/lib -lltdl -lXext -lX11

/usr/lib/libfreetype.so -lz -lm -Wl,-soname -Wl,libImlib2.so.1 -o

.libs/libImlib2.so.1.1.1

/usr/bin/ld: cannot find -lltdl

collect2: ld returned 1 exit status

make[2]: *** [libImlib2.la] Error 1

make[2]: Leaving directory `/usr/src/enlightenment+dep/imlib2-1.1.1/src'

make[1]: *** [all-recursive] Error 1

make[1]: Leaving directory `/usr/src/enlightenment+dep/imlib2-1.1.1'

make: *** [all-recursive-am] Error 2

[root@HAL9000 imlib2-1.1.1]#

i notice the the problem is -lltdl, now in the imlib2-1.06 package there is

a libltdl/ folder, this is absent from imlib2-1.1.1. does anyone have any

idea whats wrong?

any help would be appreciated :)

29 May 2003 03:55 steene

Re: ./loaders compilation problem

>
> %
> % % It would be nice if Makefile.in in
> % % the loaders/ directory was changed
> % % from:
> % %
> % % LDFLAGS = -L/usr/X11R6/lib
> % % -L$(top_builddir)/src
> % %
> % % to:
> % %
> % % LDFLAGS = -L/usr/X11R6/lib
> % % -L$(top_builddir)/src
> % % -L$(top_builder)/src/.libs
> % %
> % % I found that telling it where one
> % % of the libraries it had just compiled (and
> % % was looking for) helped it compile.
> % %
> % % :)
> %
> %
> % Actuallly, both of the above lines
> % still don't work.
>
>
> Okay, it appears as though ImLib2 1.06
> is not sufficient on its own.
>


Just try this

cat loaders/Makefile \
| sed 's/LDFLAGS = -L\/usr\/X11R6\/lib -L$(top_builddir)\/src/& -L$(top_buildir)\/src\/\.libs/g' \
> tmpMak
mv tmpMak loaders/Makefile
cat loaders/Makefile \
| sed 's/lImlib2/src\/\.libs\/libImlib2.la/g' \
> tmpMak

which is to say :
Every reference to Imlib2 in the make file is done
by giving the full path.
I have absolutely no idea why this works ..
The reason why I used the 'la' extension is that
references in the make file appears in the settings of
'something_LA_something' variables ..
This must be a true hack

24 Apr 2003 22:25 funkknight

Re: ./loaders compilation problem

> It would be nice if Makefile.in in the
> loaders/ directory was changed from:
>
> LDFLAGS = -L/usr/X11R6/lib
> -L$(top_builddir)/src
>
> to:
>
> LDFLAGS = -L/usr/X11R6/lib
> -L$(top_builddir)/src
> -L$(top_builder)/src/.libs
>
> I found that telling it where one of the
> libraries it had just compiled (and was
> looking for) helped it compile.
>
> :)

Slight error in the code above. The line should be:


LDFLAGS = -L/usr/X11R6/lib -L$(top_builddir)/src -L$(top_builddir)/src/.libs


The diff being that the variable in the last part was mistyped (top_builder as compared to top_builddir).

24 Dec 2002 01:14 aviyag

Re: Broken dependencies
i think it's time for enlightenment guys to do a release , which compiles ...
since imlib2 is used by some tools already, and there are
compile install problems on almost every platform...

22 Dec 2002 16:16 thejus

Re: ./loaders compilation problem

>
> % It would be nice if Makefile.in in
> the
> % loaders/ directory was changed from:
> %
> % LDFLAGS = -L/usr/X11R6/lib
> % -L$(top_builddir)/src
> %
> % to:
> %
> % LDFLAGS = -L/usr/X11R6/lib
> % -L$(top_builddir)/src
> % -L$(top_builder)/src/.libs
> %
> % I found that telling it where one of
> the
> % libraries it had just compiled (and
> was
> % looking for) helped it compile.
> %
> % :)
>
>
> Actuallly, both of the above lines still
> don't work. When running make in
> /loaders, the compile fails with the
> following message:
>
> /bin/sh ../libtool --mode=link gcc -g
> -O2 -L/usr/X11R6/liB -L../src
> -L/src/.libs -o jpeg.la -rpath
> /usr/lib/loaders/image -no-undefined
> -module -avoid-version loader_jpeg.lo
> -ljpeg -L../src -lImlib2
> rm -fr .libs/jpeg.la .libs/jpeg.*
> .libs/jpeg.*
> gcc -shared loader_jpeg.lo
> -L/usr/X11R6/liB -L../src -L/src/.libs
> -ljpeg -lImlib2 -lc -Wl,-soname
> -Wl,jpeg.so -o .libs/jpeg.so
> /usr/bin/ld: cannot find -lImlib2
> collect2: ld returned 1 exit status
> make: *** [jpeg.la] Error 1
>
> What do I have to do to make the
> compiler find Imlib2?
>
> Please help !!


Okay, it appears as though ImLib2 1.06 is not sufficient on its own. That is, If you do not have a previous version of ImLib2 installed, than the source tree provided in v1.06 will not have all of the required code in it. For those installing ImLib2 for the first time, I recommend the following:

Download and instal version 1.0.5. The source tree should compile and install without incident.
Download and instal version 1.0.6 next. The compile should then find everything it needs.

I had to instal 1.0.5 first on my machine. 1.0.6 would not work strait up, kept complaining that an ImLib2 library was missing (probably due to something installed in previous versions).

19 Dec 2002 18:32 thejus

Re: ./loaders compilation problem

> It would be nice if Makefile.in in the
> loaders/ directory was changed from:
>
> LDFLAGS = -L/usr/X11R6/lib
> -L$(top_builddir)/src
>
> to:
>
> LDFLAGS = -L/usr/X11R6/lib
> -L$(top_builddir)/src
> -L$(top_builder)/src/.libs
>
> I found that telling it where one of the
> libraries it had just compiled (and was
> looking for) helped it compile.
>
> :)


Actuallly, both of the above lines still don't work. When running make in /loaders, the compile fails with the following message:

/bin/sh ../libtool --mode=link gcc -g -O2 -L/usr/X11R6/liB -L../src -L/src/.libs -o jpeg.la -rpath /usr/lib/loaders/image -no-undefined -module -avoid-version loader_jpeg.lo -ljpeg -L../src -lImlib2
rm -fr .libs/jpeg.la .libs/jpeg.* .libs/jpeg.*
gcc -shared loader_jpeg.lo -L/usr/X11R6/liB -L../src -L/src/.libs -ljpeg -lImlib2 -lc -Wl,-soname -Wl,jpeg.so -o .libs/jpeg.so
/usr/bin/ld: cannot find -lImlib2
collect2: ld returned 1 exit status
make: *** [jpeg.la] Error 1

What do I have to do to make the compiler find Imlib2?

Please help !!

20 Oct 2002 18:04 chiselwright

./loaders compilation problem
It would be nice if Makefile.in in the loaders/ directory was changed from:

LDFLAGS = -L/usr/X11R6/lib -L$(top_builddir)/src

to:

LDFLAGS = -L/usr/X11R6/lib -L$(top_builddir)/src -L$(top_builder)/src/.libs

I found that telling it where one of the libraries it had just compiled (and was looking for) helped it compile.

:)

02 Nov 2001 23:53 cmcginty

Compile with GIF library
I can't get Imlib2 to recognize a GIF library on my system. I installed both libgif and libungif with no success. If anyone knows how to get around this please post. The error message I get is:

checking for DGifOpenFileName in -lungif... (cached) no
checking for DGifOpenFileName in -lgif... (cached) no
configure: warning: *** Native GIF support will not be built (GIF library not found) ***

Screenshot

Project Spotlight

ReciJournal

An open, cross-platform journaling program.

Screenshot

Project Spotlight

Veusz

A scientific plotting package.