Projects / imlib

imlib

Imlib is an advanced replacement library for libraries like libXpm that provides many more features with much greater flexibility and speed. It was originally written for E, now used by the GNOME Project.

Tags
Licenses

Recent releases

  •  18 Jul 2002 22:34

    No changes have been submitted for this release.

    •  08 Apr 2001 19:59

      No changes have been submitted for this release.

      •  23 Mar 2001 06:32

        Release Notes: This is the last release of Imlib1

        •  27 Oct 1999 16:35

          Release Notes: Changes to the build scripts to get around unexpected things that cause compiling to fail, and minor bug fixes.

          •  12 Oct 1999 00:13

            Release Notes: Bug fixes.

            Recent comments

            15 Jun 2002 21:24 eacepayeakermaye

            Re: Critical Dependencies
            I decided on gdk_pixbuf from :
            http://rpmfind.net/linux/rpm2html/search.php?query=gdk-pixbuf&submit=Search+...&system=&arch=

            04 Feb 2002 04:04 learfox

            Critical Dependencies


            Imlib makes image loading incredibly easier for
            both the user and developer of programs
            that display images, however the installation
            difficulties are extreme and many of Imlib's mandatory dependencies are on the edge of being abandoned or are never going to be completed.


            A significant number of programs depend on
            Imlib as of this writing, but many of Imlib's
            own dependencies (such as the font library)
            are not even compilable on UNIXes. To worsen
            this stress, Imlib itself is not being maintained
            enough to keep up with these issues. If one
            of Imlib's dependencies is abandoned, Imlib
            becomes completely useless.


            I cannot stress it enough that Imlib really
            needs better maintainance, along with more
            sensitive and proficient management of its
            numerous mandatory dependencies... or perhaps make
            those dependencies optional instead of mandatory.

            08 Mar 1999 04:49 shaman

            Breaks under Solaris
            Releases 1.9.3-1.9.4 have been broken under Solaris 7, the intl.h library is causing the problem.

            Screenshot

            Project Spotlight

            OpenStack4j

            A Fluent OpenStack client API for Java.

            Screenshot

            Project Spotlight

            TurnKey TWiki Appliance

            A TWiki appliance that is easy to use and lightweight.