Comments for HP Web JetAdmin

20 Dec 2007 15:34 infotek

Re: HP dropped linux support clarification
Those instructions are very version dependent. The version being Slackware 12.0.


To debug the install I started the install in one terminal, then used another terminal to preserve the data it extracted into "/tmp/". In that data extracted was the install script and all the binary files.

I used either strace on the installer or read a script (can't remember) to discover and resolve the linux version checker.

"hpwebjetd" the binary file that is dynamically linked to libraries that were not installed on Slackware 12.0. "ldd hpwebjetd" showed me what dependencies were missing. I fixed the missing dependencies by creating symbolic links to compatible libraries I did have on my system.

apr was installed because it is used by the installer and maybe the program itself but was not on my system.

Jason Ellison

23 Oct 2007 18:31 infotek

HP dropped linux support
HP appears to have dropped Linux support for HP Web Jetadmin after version 8.1 !

Installing HP WebJetadmin 8.1 (Linux) on Slackware 12.0

Obtain HP WebJetadmin 8.1 for Linux from:

http://www.hp.com/bizsupport/wja/live/manual/8.1/html/wjacomp_linux.html

echo "Red Hat Linux release 7.3 (Valhalla)" > /etc/redhat-release

cd /usr/lib/

ln -s libssl.so.0.9.8 libssl.so.0.9.6

ln -s libcrypto.so.0.9.8 libcrypto.so.0.9.6

ln -s libdb-4.2.so libdb-4.0.so

http://apache.siamwebhosting.com/apr/apr-0.9.16.tar.bz2

./configure ; make ; make install ;

http://apache.siamwebhosting.com/apr/apr-util-0.9.15.tar.bz2

./configure --with-apr=/usr/local/apr ; make ; make install ;

init script: /etc/rc.d/init.d/hpwebjetd

Jason Ellison <infotek@gmail.com>

26 Mar 2002 00:40 imillsom

Thank god for simplicity
I run a debian 2.2 machine, and wanted to install the webjet admin.

The only checking that the install application does is verify the /etc/redhat-release

so if it doesnt exist, create it with the following:
Red Hat Linux release 7.1 (Seawolf)

You may also get a error about a missing libc6.1-1.so.2 or something equiv
cd /usr/lib
ln -s libstdc++-libc6.1-2.so.3 libstdc++-libc6.1-1.so.2
and then rerun the setup. All will be sweet.

Enjoy

18 Nov 2000 23:46 drpenguin

HP Web JetAdmin - looks like both SUSE and RedHat now supported
I just went to HP's site and it looks like HP now has downloads and support for both SUSE and Redhat for their Web JetAdmin.

15 Jun 2000 19:43 bensode

SuSE 6.4
Installs great but it refuses to locate any JetDirect cards on the network. Discovery fails to locate any of the older JetDirect cards ... oh well looks like we go back to the OLD W95 Jet Admin kit ...

09 May 2000 14:09 alanprescott

Red Hat Only!
The only Linux distro HP support is Red Hat. I pulled down the rpm for the previous version and installed it under SuSE 6.3 with no probs. If you want any tech support from HP you have to lie to them and say it's on Red Hat or they don't want to know - Grr!

Screenshot

Project Spotlight

ReciJournal

An open, cross-platform journaling program.

Screenshot

Project Spotlight

Veusz

A scientific plotting package.