Comments for Apache Toolbox

10 Aug 2005 04:26 thegrinch

Version 1.5.70
Greetings<br>

Can anybody let me know where I can download ApacheToolbox-1.5.70.

I've downloaded V1.5.72 compiled but I get the following errors when I type 'make' in apache-1.3.31 directory on Debian 3.0:

-----------------------------------------------------------------------

If there where _no_ errors run "cd apache_1.3.31;make" now.

Follow the instructions to make the SSL certificate before you install apache.

Run "make install" in the apache source directory to install

apache 1.3.31 after you've successfully compiled it.

Please visit www.apachetoolbox.com for updates and the support forum.

-----------------------------------------------------------------------

bos1:/tmp/Apachetoolbox-1.5.72# cd apache_1.3.31

bos1:/tmp/Apachetoolbox-1.5.72/apache_1.3.31# make

===> src

make[1]: Entering directory `/tmp/Apachetoolbox-1.5.72/apache_1.3.31'

make[2]: Entering directory `/tmp/Apachetoolbox-1.5.72/apache_1.3.31/src'

===> src/os/unix

gcc -c -I/tmp/Apachetoolbox-1.5.72/src/mm-1.3.0 -I../../os/unix -I../../include -DLINUX=22 -DHAVE_SET_DUMPABLE -I/usr/include/db1 -DMOD_SSL=208119 -DEAPI -DEAPI_MM -DUSE_EXPAT -I../../lib/expat-lite `../../apaci` os.c

gcc -c -I/tmp/Apachetoolbox-1.5.72/src/mm-1.3.0 -I../../os/unix -I../../include -DLINUX=22 -DHAVE_SET_DUMPABLE -I/usr/include/db1 -DMOD_SSL=208119 -DEAPI -DEAPI_MM -DUSE_EXPAT -I../../lib/expat-lite `../../apaci` os-inline.c

rm -f libos.a

ar cr libos.a os.o os-inline.o

ranlib libos.a

<=== src/os/unix

===> src/ap

gcc -c -I/tmp/Apachetoolbox-1.5.72/src/mm-1.3.0 -I../os/unix -I../include -DLINUX=22 -DHAVE_SET_DUMPABLE -I/usr/include/db1 -DMOD_SSL=208119 -DEAPI -DEAPI_MM -DUSE_EXPAT -I../lib/expat-lite `../apaci` ap_cpystrn.c

In file included from ../include/httpd.h:31,

from ap_cpystrn.c:16:

../include/buff.h:86: parse error before `ap_ctx'

../include/buff.h:86: warning: no semicolon at end of struct or union

../include/buff.h:97: parse error before `}'

make[3]: *** [ap_cpystrn.o] Error 1

make[2]: *** [subdirs] Error 1

make[2]: Leaving directory `/tmp/Apachetoolbox-1.5.72/apache_1.3.31/src'

make[1]: *** [build-std] Error 2

make[1]: Leaving directory `/tmp/Apachetoolbox-1.5.72/apache_1.3.31'

make: *** [build] Error 2

bos1:/tmp/Apachetoolbox-1.5.72/apache_1.3.31# cd ..

29 Nov 2001 10:47 bandrews

Re: good program small bug

> overall good program, but you should put
> some type of timeout for the downloading
> fuctions when it can't contact a
> specific server
>


I use wget to download needed source tarballs, which uses a 2 second timeout. You can change the timeout to whatever you'd like in etc/defaults.conf.

24 Sep 2001 02:12 t3kn0

very helpful
i did find myself having to go back and turn off features(which i didnt need to begin with so im not complaining either) that were giving me errors...
awesome script though, saved me (hours X several machines) = days! over doing apacompile by hand as i have been doing.
I have been building LAMP machines each different than the last so this is a godsend for me!
great timesaver and for those less technical it sure makes things much easier..VERY FULL FEATURED TOO!

23 Sep 2001 23:02 t3kn0

very helpful
i did find myself having to go back and turn off features(which i didnt need to begin with so im not complaining either) that were giving me errors...
awesome script though, saved me (hours X several machines) = days! over doing apacompile by hand as i have been doing.
I have been building LAMP machines each different than the last so this is a godsend for me!
great timesaver and for those less technical it sure makes things much easier..VERY FULL FEATURED TOO!

31 Aug 2001 04:03 OranjC

good program small bug
overall good program, but you should put some type of timeout for the downloading fuctions when it can't contact a specific server

26 Mar 2001 18:16 bandrews

Re: Great system, minor problem

>
> % This script is great, but it
> doesn't
> % look for PostgreSQL in the default
> % location (/usr/local/pgsql) when
> % configuring php. Small change to
> fix
> % this. Just add:
> %
> % test -f
> % /usr/local/pgsql/include/libpq-fe.h
> &&
> % INSTALL_PHP_POSTGRES=$TRUE
> %
> % to
> %
> Apachetoolbox-version/bin/php-postgres.
>
>
>
> In my default Debian 2.2r2 Install
> Postgres was in /usr/include/postgresql
> .... Same as above, just a different
> path.. Works great.
>


Added to 1.5.15+

22 Mar 2001 16:57 SuperZero

Re: Great system, minor problem

> This script is great, but it doesn't
> look for PostgreSQL in the default
> location (/usr/local/pgsql) when
> configuring php. Small change to fix
> this. Just add:
>
> test -f
> /usr/local/pgsql/include/libpq-fe.h &&
> INSTALL_PHP_POSTGRES=$TRUE
>
> to
> Apachetoolbox-version/bin/php-postgres.


In my default Debian 2.2r2 Install Postgres was in /usr/include/postgresql .... Same as above, just a different path.. Works great.

16 Mar 2001 10:48 Ironcraft

Re: Get your Webserver Started Quickly
I can agree, and it gets better and better ...
(always up to date with the modules)

Great work

09 Mar 2001 17:04 bandrews

Re: Great system, minor problem

> This script is great, but it doesn't
> look for PostgreSQL in the default
> location (/usr/local/pgsql) when
> configuring php. Small change to fix
> this. Just add:
>
> test -f
> /usr/local/pgsql/include/libpq-fe.h &&
> INSTALL_PHP_POSTGRES=$TRUE
>
> to
> Apachetoolbox-version/bin/php-postgres.


This has been added to v1.5.14+ , thanks for the tip!

28 Feb 2001 06:03 ostermer

Great system, minor problem
This script is great, but it doesn't look for PostgreSQL in the default location (/usr/local/pgsql) when configuring php. Small change to fix this. Just add:

test -f /usr/local/pgsql/include/libpq-fe.h && INSTALL_PHP_POSTGRES=$TRUE

to Apachetoolbox-version/bin/php-postgres.

Screenshot

Project Spotlight

ReciJournal

An open, cross-platform journaling program.

Screenshot

Project Spotlight

Veusz

A scientific plotting package.